AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

1998.08.17 17:30 "Missing image.h file while compiling", by Bruce Sedlacek
1998.08.17 17:35 "Re: Missing image.h file while compiling", by Sam Leffler
1998.08.17 21:32 "Re: Missing image.h file while compiling", by Bruce Sedlacek

1998.08.17 17:30 "Missing image.h file while compiling", by Bruce Sedlacek

Please reply to me directly at bs@vantek.net as I am not subscribed to this list. Thanks in advance.

I downloaded the file tiff-v3.4-tar.gz which extracted the directory as tiff-v3.4beta035/, so I am assuming I've got version 3.4beta035.

I'm compiling and running on BSDi 3.1 (with all current patches).

I used the sample config.local file to set it to install in /usr/contrib, and the make process started fine, but when it got to sgi2tiff.c, it gave this error:

/usr/bin/gcc -c -g -O -I. -I../tools -I../libtiff ../tools/sgi2tiff.c
../tools/sgi2tiff.c:30: gl/image.h: No such file or directory
*** Error code 1

Stop.
*** Error code 1

Stop.
*** Error code 1

Stop.

I am unable to locate the image.h file on my hard drive, nor can I find the gl directory. Could this be due to the fact that we did not install X on this machine?

Any help or suggestions would be greatly appreciated. I need to get this compiled so that I can compile the current version of HylaFax because the version 4.0pl0 that BSDi ships craps out all the time. <G>

And yet more thanks in advance!!!

Bruce Sedlacek
Systems Administrator
Vantek / VTservers


Editor's note: This mail was not originally archived, and has been reconstructed from quotes.