AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2001.04.02 14:08 "libtiff on Darwin 1.2.1", by
2001.04.03 03:33 "Re: libtiff on Darwin 1.2.1", by Leonard Rosenthol
2001.04.03 06:00 "Re: libtiff on Darwin 1.2.1", by
2001.04.03 06:07 "Re: libtiff on Darwin 1.2.1", by Frank Warmerdam
2001.04.19 20:53 "Re: libtiff on Darwin 1.2.1", by
2001.04.20 19:25 "Re: libtiff on Darwin 1.2.1", by
2001.04.20 18:23 "Re: libtiff on Darwin 1.2.1", by Frank Warmerdam

2001.04.03 03:33 "Re: libtiff on Darwin 1.2.1", by Leonard Rosenthol

At 4:08 PM +0200 4/2/01, LHelldorf@kabel.de wrote:

I tried to install libtiff on Darwin 1.2.1

I haven't tried it on Darwin, but libtiff (or at least the libtiff distro included with ImageMagick) compiles just fine on Mac OS X.

after unpacking the tarball tiff-v3.5.6-beta.tar.gz I entered ./configure. the result was that configure or better config.guess couldn't recognize my machine.

I replaced config.guess with config.guess found in /usr/libexec/. ./configure worked this time!

Yup, you have to do this sometimes...

I can send you a copy of this config.guess if you want to. Then I entered make.

After a while and a lot of console output the following message appeared: /usr/bin/ld: can't locate file for: -lm and some error messages after this.

What can I do about it?

It has to do with how libraries are built - and you need to change it.

Leonard
--

----------------------------------------------------------------------------
                   You've got a SmartFriend� in Pennsylvania
----------------------------------------------------------------------------

Leonard Rosenthol                       Internet:       leonardr@lazerware.com

Web Site: <http://www.lazerware.com/>
Coola Signature: <http://signature.coola.com/?leonardr@lazerware.com>
PGP Fingerprint: C76E 0497 C459 182D 0C6B AB6B CA10 B4DF 8067 5E65