AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2007.03.27 06:49 "[Tiff] "compiling libtiff using libjpeg under windows"", by Penumalli Madhavi
2007.03.27 07:26 "Re: [Tiff] "compiling libtiff using libjpeg under windows"", by alexander johnson
2007.03.27 07:51 "Re: [Tiff] "compiling libtiff using libjpeg under windows"", by Andrey Kiselev
2007.04.27 21:05 "[Tiff] Compiling libtiff on windows.....", by Pavan Kumar Tiruveedhula

2007.04.27 21:05 "[Tiff] Compiling libtiff on windows.....", by Pavan Kumar Tiruveedhula

Hi,

Caould someone help me how to resolve the libtiff compiling errors on windows. At first I started off using the makefile with nmake utility and it asked me for jpeg.lib, so then I downloaded jpeg library and generated jpeg.lib and copied all the necessary header files into libtiff folder, then again it asked for zlib file, again I went back and downloaded zlib library and generated zlib.lib and copied all the necessary header files into libtiff folder, now it gives me linker errors as follows....

Creating library libtiff_i.lib and object libtiff_i.exp

tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_read_header
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_resync_to_restart
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_start_decompress
tif_jpeg.obj : error LNK2001: unresolved external symbol _jpeg_abort
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_read_scanlines
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_finish_decompress
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_read_raw_data
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_set_defaults
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_set_quality
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_suppress_tables
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_write_tables
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_set_colorspace
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_start_compress
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_write_scanlines
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_write_raw_data
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_finish_compress
tif_jpeg.obj : error LNK2001: unresolved external symbol _jpeg_destroy
tif_jpeg.obj : error LNK2001: unresolved external symbol
_jpeg_CreateCompress
tif_jpeg.obj : error LNK2001: unresolved external symbol _jpeg_std_error
tif_jpeg.obj : error LNK2001: unresolved external symbol

_jpeg_CreateDecompress
libtiff.dll: fatal error LNK1120: 20 unresolved externals
NMAKE: fatal error U1077: 'link': return code '0x460'
Stop.

I am not sure whats goin on and its soo frustrating as I was trying to get it working from 2 full days. I have generated all the other libraries with /MTd option and I even changed that option in opt file of libtiff....

Any help??

-thanks...