AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2003.12.29 16:04 "[Tiff] Jpeg Compression causing black lines in 3.6.1", by Carl J. Collin
2004.01.02 15:14 "Please don't post large files (was: [Tiff] Jpeg Compression causing black lines in 3.6.1)", by Rich Pasco
2004.01.02 15:27 "Re: Please don't post large files (was: [Tiff] Jpeg Compression causing black lines in 3.6.1)", by Carl J. Collin

2003.12.29 16:04 "[Tiff] Jpeg Compression causing black lines in 3.6.1", by Carl J. Collin

In version 3.5.7 I was able to take an image file that had a RowsPerStrip that was off of the 8K boundary and create a JPEG compressed Tiff file and then revert it back with hardly any degradation in quality. In version 3.6.X, I am unable to convert my file using JPEG compression because it gives an error due to my RowsPerStrip not being a multiple of 8. So, I converted it using "tiffcp -r" so that it had a value that was a multiple of 8. Now I can compress it, but when I decompress it I get a file with big black lines every couple of inches. As if there are black lines on each strip. Does anyone know why JPEG compression/decompression seems to have become broken with the 3.6.X series? Or am I doing something wrong.... I would greatly appreciate if somebody can give me a hand. I am in a catch-22. I need the 3.6.X series to handle a Custom Tag and yet the 3.5.7 series is the only one that seems to do compression correctly.

Thanks,

Carl

I have attached all of my types of files, including the

Original
Original and I fixed the RowsPerStrip using tiffcp -r
Compressed
Decompressed