AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2017.03.04 10:59 "[Tiff] started seeing breakage with libtiff", by John
2017.03.04 12:10 "Re: [Tiff] started seeing breakage with libtiff", by Even Rouault
2017.03.04 13:08 "Re: [Tiff] started seeing breakage with libtiff", by John
2017.03.04 18:51 "Re: [Tiff] started seeing breakage with libtiff", by John
2017.03.04 19:19 "Re: [Tiff] started seeing breakage with libtiff", by Bob Friesenhahn
2017.03.04 19:53 "Re: [Tiff] started seeing breakage with libtiff", by Even Rouault
2017.03.05 09:53 "Re: [Tiff] started seeing breakage with libtiff", by John
2017.03.06 15:29 "Re: [Tiff] started seeing breakage with libtiff", by Lee Howard
2017.03.06 15:46 "Re: [Tiff] started seeing breakage with libtiff", by Bob Friesenhahn
2017.03.06 15:59 "Re: [Tiff] started seeing breakage with libtiff", by Toby Thain
2017.03.06 16:26 "Re: [Tiff] started seeing breakage with libtiff", by Lee Howard

2017.03.06 15:29 "Re: [Tiff] started seeing breakage with libtiff", by Lee Howard

On 03/04/2017 10:51 AM, jcupitt@gmail.com wrote:

For reference, the problem is in tiff_4.0.6-2ubuntu0.1, the version currently being used in 16.10. Plain 4.0.6 seems to work, but one of the (very many) patches Ubuntu is applying has broken stuff.

I wish package maintainers at the various distros wouldn't glamorize patches as they seem to do. They should be involved in the upstream project development and seek to integrate as many patches as possible so that the only patches they apply are truly distribution-specific. Most customization patches can still be upstreamed and enabled with build-time flags.

Thanks,

Lee.